Author Topic: Defective SL520 compressors. Need help and/or complete schematics.  (Read 518 times)

Helterbelter

  • Newbie
  • *
  • Posts: 44
  • Karma: +3/-0
    • Zevenaar, The Netherlands
i've got 2 520's, and both have the same flaw : the release doesn't not work properly.

The (negative) CV value is too high. With the the threshold all the way up, and the fastest release setting it already compresses a few dB's, but in the slower release settings including the autorelease, it compresses so extremely, almost no sound comes out anymore.  The compression led bar lights up the full range. I have checked almost everything there is to check :  the voltages applied to the ratiocircuit, the transistors, the switches itself of course, the SC-vca's. Checked the electrolyts. Checked the 10M resistor parallel to the release switch, all fine.

I consider changing the 10M resistor to 3M9, (the value used in the G384), but this would merely be a patchsolution, not even sure it'll work. I prefer to fix the 520s as they should be.

So, I want to check more, but....... I have an incomplete manual. I have 4 different manuals from different sources (including the one from Mattia), but none have the part of  the limiter section, and the gainmakeup is missing as well.  The indexes of the manuals don't mention this either, so, I think SSL forgot the include these. But maybe somebody here has it, so......

I'm not even so sure the fault will be there, but, well.... I think it'd be nice to have it complete anyway.

Another thing : does anybody here know what to measure at the testpoints T1 to T4 ?



On a sidenote, the last few weeks I've been comparing the schematics of the 520, the G384, and the GSSL a lot. A few interesting differences came to surface.

The audiopath itself is (fairly) identical on both compressors. Both use the 85501 and 85502 (de-)balancing chips and use the same DBX 202 Xt VCA's.

The sidechain is different. The way the audio is rectified is different, the voltages for supply in both  the ratiocircuit and the threshold circuit are different. There are bufferamps in the ratio and release circuits of the 520.
And the one thing that I found quite a suprise : in the G384, the attackcircuit comes before the release, and in the 520 it’s the other way, and, there’s the bufferamp in between.
Another thing that might give quite a different result, is that in the 520 the left and right channels are summed before the ratiocircuit, and in the G384 it is summed after the ratio circuit.

The G-SSL clone’s sidechain circuit, together with a Turbo board, are identical to the G384.

But well.... This post is mainly to ask you if you have an idea what might be wrong.






matt

  • Jr. Member
  • **
  • Posts: 82
  • Karma: +2/-0
    • Reutlingen, Germany
Re: Defective SL520 compressors. Need help and/or complete schematics.
« Reply #1 on: November 28, 2015, 10:58:04 PM »
Can you post the drawing numbers you already have ?

Helterbelter

  • Newbie
  • *
  • Posts: 44
  • Karma: +3/-0
    • Zevenaar, The Netherlands
Re: Defective SL520 compressors. Need help and/or complete schematics.
« Reply #2 on: November 29, 2015, 09:02:08 PM »
Sure !
85020:  71, 72, 73, 74
85120 : 71, 72, 73, 74
85220.71, 85320.71, 85420.71

OT : By the way, thanks for the CCR of the 595 !

matt

  • Jr. Member
  • **
  • Posts: 82
  • Karma: +2/-0
    • Reutlingen, Germany
Re: Defective SL520 compressors. Need help and/or complete schematics.
« Reply #3 on: November 30, 2015, 07:13:50 PM »
Unfortunately I don't have any other than that.

Helterbelter

  • Newbie
  • *
  • Posts: 44
  • Karma: +3/-0
    • Zevenaar, The Netherlands
Re: Defective SL520 compressors. Need help and/or complete schematics.
« Reply #4 on: November 30, 2015, 09:25:30 PM »
too bad, but thanks for checking though !

Helterbelter

  • Newbie
  • *
  • Posts: 44
  • Karma: +3/-0
    • Zevenaar, The Netherlands
Re: Defective SL520 compressors. Need help and/or complete schematics.
« Reply #5 on: December 03, 2015, 07:12:40 AM »
I consider changing the 10M resistor to 3M9, (the value used in the G384), but this would merely be a patchsolution, not even sure it'll work. I prefer to fix the 520s as they should be.

Well, this didn't work out, the problem persists....


Aside the missing part of the schematics,
Another thing : does anybody here know what to measure at the testpoints T1 to T4 ?
This especially would be of great value to the forum. And to me as well of course !
 ;)

keyrob

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • Padua
Re: Defective SL520 compressors. Need help and/or complete schematics.
« Reply #6 on: March 06, 2017, 06:29:45 PM »
I too have the same problem but I have no schematics.
Can anyone provide me so that I can try to repair?
Thank you
Roberto

Matt Sartori

  • Administrator
  • Hero Member
  • *****
  • Posts: 580
  • Karma: +18/-0
    • London
    • Solid State Logic Fanatics Database
Re: Defective SL520 compressors. Need help and/or complete schematics.
« Reply #7 on: March 07, 2017, 04:38:45 PM »
I too have the same problem but I have no schematics.
Can anyone provide me so that I can try to repair?
Thank you
Roberto

please check the manuals and documentation section here:

http://forum.sslmixed.com/index.php/topic,274.0.html

Matt.